REDTREE Desk and CRM Upgrades
Incident Report for REDTREE GmbH
Resolved
IQ Integration done.
Posted Jul 22, 2017 - 02:47 CEST
Monitoring
We are updating our Systems over the Weekend in order to catch up to the latested CVC-Reports. Furthermore there will be some new features that we will now launch regardless of the Development-Roadmap. For any Service-Request please mail us: service@redtree.de or call us under 0800 0977610.
Posted Jun 30, 2017 - 21:05 CEST